Zum Inhalt

Java8+ / Android API Level < 26 Support

Wenn Ihre App Geräte mit einem API Level unter 26 unterstützt, müssen neuere Java 8 Funktionen im Buildprozess inkludiert werden ("Desugaring").

Dazu muss die Gradle Build Configuration der Application wie folgt angepasst werden:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
android {
    defaultConfig {
        // Required when setting minSdkVersion to 20 or lower
        multiDexEnabled true
    }

    compileOptions {
        // Flag to enable support for the new language APIs
        coreLibraryDesugaringEnabled true
        // Sets Java compatibility to Java 8
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
}

dependencies {
    coreLibraryDesugaring 'com.android.tools:desugar_jdk_libs:1.1.5'
}

Weitere Informationen und die aktuellste Version der Desugaring Library können der offiziellen Android Developer Dokumentation entnommen werden: https://developer.android.com/studio/write/java8-support


Letztes Update: February 11, 2022